From:  nbeletsky@beget.ru ("nbeletsky")
Date:  04 Mar 2017 20:08:28 Hong Kong Time
Newsgroup:  news.php.net/php.pear.bugs
Subject:  

[PEAR-BUG] Bug #21190 [Com]: I am unable to install pear

NNTP-Posting-Host:  null

Edit report at http://pear.php.net/bugs/bug.php?id=21190&edit=1

 ID:               21190
 Comment by:       nbeletsky
 Reported By:      nbeletsky at beget dot ru
 Summary:          I am unable to install pear
 Status:           Closed
 Type:             Bug
 Package:          pearweb_phars
 Operating System: macOS 10.12.3
 PHP Version:      5.6.21
 Assigned To:      ashnazg
 New Comment:

Hi!
When will be updated:
https://pear.php.net/install-pear-nozlib.phar
?
It is used when building PHP and there is still the old version.


Previous Comments:
------------------------------------------------------------------------

[2017-03-01 09:11:49] ashnazg

-Status: Assigned +Status: Closed
Fixed in 1.10.4 just released... thanks for the bug report! ------------------------------------------------------------------------ [2017-03-01 09:05:37] ashnazg
-Package: PEAR +Package: pearweb_phars
------------------------------------------------------------------------ [2017-03-01 08:51:31] ashnazg
-Assigned To: +Assigned To: ashnazg
------------------------------------------------------------------------ [2017-03-01 07:29:38] rochwald Description: ------------ After running "$ sudo php -d detect_unicode=0 go-pear.phar" I get a Warning that terminates the installation process. Test script: --------------- $ sudo php -d detect_unicode=0 go-pear.phar Expected result: ---------------- Installed PEAR on macOS. Actual result: -------------- Beginning install... Configuration written to /Users/rok/.pearrc... Initialized registry... Preparing to install... installing phar:///Users/rok/go-pear.phar/PEAR/go-pear- tarballs/Archive_Tar-1.4.2.tar... installing phar:///Users/rok/go-pear.phar/PEAR/go-pear- tarballs/Console_Getopt-1.4.1.tar... installing phar:///Users/rok/go-pear.phar/PEAR/go-pear-tarballs/PEAR- 1.10.3.tar... installing phar:///Users/rok/go-pear.phar/PEAR/go-pear- tarballs/Structures_Graph-1.1.1.tar... installing phar:///Users/rok/go-pear.phar/PEAR/go-pear-tarballs/XML_Util- 1.4.2.tar... PHP Warning: require_once(phar://go-pear.phar/PEAR/Proxy.php): failed to open stream: phar error: "PEAR/Proxy.php" is not a file in phar "go- pear.phar" in phar:///Users/rok/go -pear.phar/PEAR/Downloader.php on line 23 PHP Stack trace: PHP 1. {main}() /Users/rok/go-pear.phar:0 PHP 2. require_once() /Users/rok/go-pear.phar:1271 PHP 3. PEAR_Start_CLI->run() phar:///Users/rok/go- pear.phar/index.php:5 PHP 4. PEAR_Start->doInstall() phar:///Users/rok/go- pear.phar/PEAR/Start/CLI.php:72 PHP 5. PEAR_Command_Common->run() phar:///Users/rok/go- pear.phar/PEAR/Start.php:345 PHP 6. PEAR_Command_Install->doInstall() phar:///Users/rok/go- pear.phar/PEAR/Command/Common.php:270 PHP 7. PEAR_Command_Install->getInstaller() phar:///Users/rok/go- pear.phar/PEAR/Command/Install.php:540 PHP 8. require_once() phar:///Users/rok/go- pear.phar/PEAR/Command/Install.php:340 PHP 9. require_once() phar:///Users/rok/go- pear.phar/PEAR/Installer.php:23 Warning: require_once(phar://go-pear.phar/PEAR/Proxy.php): failed to open stream: phar error: "PEAR/Proxy.php" is not a file in phar "go- pear.phar" in phar:///Users/rok/go-pear .phar/PEAR/Downloader.php on line 23 Call Stack: 0.0308 311296 1. {main}() /Users/rok/go-pear.phar:0 0.0315 304600 2. require_once('phar:///Users/rok/go- pear.phar/index.php') /Users/rok/go-pear.phar:1271 0.0686 1698208 3. PEAR_Start_CLI->run() phar:///Users/rok/go- pear.phar/index.php:5 1.6761 1709952 4. PEAR_Start->doInstall() phar:///Users/rok/go- pear.phar/PEAR/Start/CLI.php:72 1.7858 2203028 5. PEAR_Command_Common->run() phar:///Users/rok/go-pear.phar/PEAR/Start.php:345 1.7858 2204384 6. PEAR_Command_Install->doInstall() phar:///Users/rok/go-pear.phar/PEAR/Command/Common.php:270 1.7867 2204436 7. PEAR_Command_Install->getInstaller() phar:///Users/rok/go-pear.phar/PEAR/Command/Install.php:540 1.7906 2454520 8. require_once('phar:///Users/rok/go- pear.phar/PEAR/Installer.php') phar:///Users/rok/go- pear.phar/PEAR/Command/Install.php:340 1.7949 2732420 9. require_once('phar:///Users/rok/go- pear.phar/PEAR/Downloader.php') phar:///Users/rok/go- pear.phar/PEAR/Installer.php:23 ------------------------------------------------------------------------ -- Edit this bug report at http://pear.php.net/bugs/bug.php?id=21190&edit=1