From:  pear-qa@lists.php.net ("jpswade@gmail.com")
Date:  06 Jan 2016 05:14:24 Hong Kong Time
Newsgroup:  news.php.net/php.pear.bugs
Subject:  

[PEAR-BUG] Bug #6348 [Com]: Using = before domain name hangs ?

NNTP-Posting-Host:  null

Edit report at https://pear.php.net/bugs/bug.php?id=6348&edit=1

 ID:               6348
 Comment by:       jpswade@gmail.com
 Reported By:      afw at finexe dot com
 Summary:          Using = before domain name hangs ?
 Status:           Closed
 Type:             Bug
 Package:          Net_Whois
 Operating System: windows 2003 server
 PHP Version:      4.4.1
 Assigned To:      kguest
 Roadmap Versions: 
 New Comment:

http://pear.php.net/bugs/bug.php?id=17484


Previous Comments:
------------------------------------------------------------------------

[2008-10-15 08:30:15] kguest

This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net
by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.

added patch and test files. Note: there are phpcs issues and the
package.xml needs to be updated to version 2 of the xml spec.
These issues are seperate from fixing the bug described here and will be
addressed seperately.

------------------------------------------------------------------------

[2008-10-15 07:36:52] doconnor

Hey Ken, got your PEAR QA hat handy?

------------------------------------------------------------------------

[2008-03-22 17:10:26] streety

Added patch for change suggested by afw at finexe dot com

I wasn't getting a timeout prior to the patch but the change appears to
not throw up any new problems.

------------------------------------------------------------------------

[2006-06-15 19:34:58] afw at finexe dot com

I solved this long ago. There was indeed a bug that made this package
very unstable for me.

Here is the change I made, and it has worked well since then:

224c224
<         if (PEAR::isError($socket->connect($nicServer,
getservbyname('whois', 'tcp')))) {
---
>         if (PEAR::isError($socket->connect($nicServer,
getservbyname('whois', 'tcp'), false, 25))) {

------------------------------------------------------------------------

[2006-01-03 09:24:44] afw at finexe dot com

Hello,

I'm on windows 2k3 (no SP) with precompiled php, and no gdb that I know
of. Is there any backtrace instructions for windows?

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=6348

-- 
Edit this bug report at https://pear.php.net/bugs/bug.php?id=6348&edit=1