From:  ohlesbeauxjours@yahoo.fr
Date:  15 Feb 2015 20:42:06 Hong Kong Time
Newsgroup:  news.php.net/php.pear.bugs
Subject:  

[PEAR-BUG] Bug #20288 [Opn->Bgs]: Can't import XMI into ArgoUML

NNTP-Posting-Host:  null

Edit report at https://pear.php.net/bugs/bug.php?id=20288&edit=1

 ID:               20288
 Updated by:       ohlesbeauxjours@yahoo.fr
 Reported By:      tw at appserver dot io
 Summary:          Can't import XMI into ArgoUML
-Status:           Open
+Status:           Bogus
 Type:             Bug
 Package:          PHP_UML
 Operating System: Mac OS X
 Package Version:  1.6.1
 PHP Version:      5.5.10
 Roadmap Versions: 
 New Comment:

-Status: Open
+Status: Bogus
There are two versions of XMI.
ArgoUML accepts only XMI 1 files. But by default, PHP_UML generates XMI
in version 2. If you want XMI 1, you have to explicitly pass the version
to PHP_UML with the switch -x, as indicated in the documentation:
https://pear.php.net/manual/en/package.php.php-uml.command-line.php
(chapter "Selecting the UML/XMI version")


Previous Comments:
------------------------------------------------------------------------

[2014-05-30 10:01:15] wagnert

Sorry, but i can't find the possibility to upload the generated .XMI
file here. If needed, i can upload it on GitHub or anywhere else you
like!

------------------------------------------------------------------------

[2014-05-30 09:43:50] wagnert

Description:
------------
I try to generate an XMI file from the sources of our project 
(appserver.io, directory /opt/appserver/app/code/vendor). The 
generation has been successfully, but when i try to open the file 
in ArgoUML for example, it shows the following error message:


XMI format error : org.argouml.model.XmiException: XMI 
parsing error at line: 4: XMI version attribute is missing.
If this file was produced by a tool other than ArgoUML, please
check to make sure that the file is in a supported format, 
including
both UML and XMI versions.

If you believe that the file is legal UML/XMI and should have 
loaded
or if it was produced by any version of ArgoUML, please report
the problem as a bug by going to 
http://argouml.tigris.org/project_bugs.html.
 System Info:
ArgoUML version : 0.34
Java Version : 1.6.0_65
Java Vendor : Apple Inc.
Java Vendor URL : http://www.apple.com/
Java Home Directory : 
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Ho
me
Java Classpath : 
/Applications/ArgoUML.app/Contents/Resources/Java/antlr-
2.7.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/ar
gouml-
euml.jar:/Applications/ArgoUML.app/Contents/Resources/Java/ar
gouml-
mdr.jar:/Applications/ArgoUML.app/Contents/Resources/Java/arg
ouml-
model.jar:/Applications/ArgoUML.app/Contents/Resources/Java/a
rgouml.jar:/Applications/ArgoUML.app/Contents/Resources/Java/
batik-awt-util-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/bati
k-dom-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/bati
k-ext-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/bati
k-svggen-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/bati
k-util-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/bati
k-xml-
1.7.jar:/Applications/ArgoUML.app/Contents/Resources/Java/com
mons-logging-
1.0.2.jar:/Applications/ArgoUML.app/Contents/Resources/Java/ge
f-
0.13.8.jar:/Applications/ArgoUML.app/Contents/Resources/Java/j
ava-
interfaces.jar:/Applications/ArgoUML.app/Contents/Resources/Ja
va/jmi.jar:/Applications/ArgoUML.app/Contents/Resources/Java/j
miutils.jar:/Applications/ArgoUML.app/Contents/Resources/Java/l
og4j-
1.2.6.jar:/Applications/ArgoUML.app/Contents/Resources/Java/m
drapi.jar:/Applications/ArgoUML.app/Contents/Resources/Java/m
of.jar:/Applications/ArgoUML.app/Contents/Resources/Java/nbmd
r.jar:/Applications/ArgoUML.app/Contents/Resources/Java/ocl-
argo-
1.1.jar:/Applications/ArgoUML.app/Contents/Resources/Java/ope
nide-
util.jar:/Applications/ArgoUML.app/Contents/Resources/Java/org.
eclipse.emf.common_2.6.0.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.ecore.change.edit_2.5.0.v20100521-
1846.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.ecore.change_2.5.1.v20100907-
1643.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.ecore.edit_2.6.0.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.ecore.xmi_2.5.0.v20100521-
1846.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.ecore_2.6.1.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.edit_2.6.0.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.mapping.ecore2xml_2.5.0.v20100521-
1847.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.mapping.ecore_2.6.0.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.emf.mapping_2.6.0.v20100914-
1218.jar:/Applications/ArgoUML.app/Contents/Resources/Java/or
g.eclipse.uml2.common.edit_1.5.0.v201005031530.jar:/Applicatio
ns/ArgoUML.app/Contents/Resources/Java/org.eclipse.uml2.com
mon_1.5.0.v201005031530.jar:/Applications/ArgoUML.app/Conte
nts/Resources/Java/org.eclipse.uml2.uml.edit_3.1.0.v201005031
530.jar:/Applications/ArgoUML.app/Contents/Resources/Java/org
.eclipse.uml2.uml.resources_3.1.1.v201008191505.jar:/Applicatio
ns/ArgoUML.app/Contents/Resources/Java/org.eclipse.uml2.uml_
3.1.1.v201008191505.jar:/Applications/ArgoUML.app/Contents/R
esources/Java/swidgets-
0.1.4.jar:/Applications/ArgoUML.app/Contents/Resources/Java/to
olbar-1.4.1-20071227.jar
Operation System : Mac OS X, Version 10.8.5
Architecture : x86_64
User Name : wagnert
User Home Directory : /Users/wagnert
Current Directory : 
/Applications/ArgoUML.app/Contents/Resources/Java
JVM Total Memory : 85000192
JVM Free Memory : 60699512


 Error occurred at : Fri May 30 09:27:01 CEST 2014
Cause : org.argouml.model.XmiException: XMI parsing error at 
line: 4: XMI version attribute is missing.
at 
org.argouml.model.mdr.XmiReaderImpl.parse(XmiReaderImpl.ja
va:341)
at 
org.argouml.persistence.ModelMemberFilePersister.readModels(M
odelMemberFilePersister.java:274)
at 
org.argouml.persistence.XmiFilePersister.doLoad(XmiFilePersister
.java:261)
at 
org.argouml.ui.ProjectBrowser.loadProject2(ProjectBrowser.java:
1626)
at 
org.argouml.ui.ProjectBrowser.loadProject(ProjectBrowser.java:1
552)
at 
org.argouml.ui.LoadSwingWorker.construct(LoadSwingWorker.ja
va:89)
at 
org.argouml.ui.SwingWorker.doConstruct(SwingWorker.java:153
)
at org.argouml.ui.SwingWorker$2.run(SwingWorker.java:281)
at java.lang.Thread.run(Thread.java:695)
Caused by: org.netbeans.lib.jmi.util.DebugException: XMI version 
attribute is missing.
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.startElement(XmiSAXRe
ader.java:232)
at 
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.s
tartElement(AbstractSAXParser.java:504)
at 
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.st
artElement(XMLDTDValidator.java:767)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl.scanStartElement(XMLDocumentFragmentScannerI
mpl.java:1370)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl$ContentDriver.scanRootElementHook(XMLDocumentScannerI
mpl.java:1316)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl$FragmentContentDriver.next(XMLDocumentFragme
ntScannerImpl.java:3115)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl$PrologDriver.next(XMLDocumentScannerImpl.java:921)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl.next(XMLDocumentScannerImpl.java:647)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.
java:513)
at 
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.
parse(XML11Configuration.java:815)
at 
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.
parse(XML11Configuration.java:744)
at 
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XM
LParser.java:128)
at 
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.p
arse(AbstractSAXParser.java:1208)
at 
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSA
XParser.parse(SAXParserImpl.java:543)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.read(XmiSAXReader.jav
a:136)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.read(XmiSAXReader.jav
a:98)
at org.netbeans.lib.jmi.xmi.SAXReader.read(SAXReader.java:56)
at 
org.argouml.model.mdr.XmiReaderImpl.parse(XmiReaderImpl.ja
va:267)
... 8 more
Caused by: org.netbeans.lib.jmi.util.DebugException: XMI version 
attribute is missing.
at 
org.netbeans.lib.jmi.xmi.XmiContext.setVersion(XmiContext.java
:210)
at org.netbeans.lib.jmi.xmi.XmiElement$Document. 
(XmiElement.java:94)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.startElement(XmiSAXRe
ader.java:169)
... 26 more
-------
Full exception : org.argouml.persistence.XmiFormatException: 
org.argouml.model.XmiException: XMI parsing error at line: 4: 
XMI version attribute is missing.
at 
org.argouml.persistence.ModelMemberFilePersister.readModels(M
odelMemberFilePersister.java:300)
at 
org.argouml.persistence.XmiFilePersister.doLoad(XmiFilePersister
.java:261)
at 
org.argouml.ui.ProjectBrowser.loadProject2(ProjectBrowser.java:
1626)
at 
org.argouml.ui.ProjectBrowser.loadProject(ProjectBrowser.java:1
552)
at 
org.argouml.ui.LoadSwingWorker.construct(LoadSwingWorker.ja
va:89)
at 
org.argouml.ui.SwingWorker.doConstruct(SwingWorker.java:153
)
at org.argouml.ui.SwingWorker$2.run(SwingWorker.java:281)
at java.lang.Thread.run(Thread.java:695)
Caused by: org.argouml.model.XmiException: XMI parsing error 
at line: 4: XMI version attribute is missing.
at 
org.argouml.model.mdr.XmiReaderImpl.parse(XmiReaderImpl.ja
va:341)
at 
org.argouml.persistence.ModelMemberFilePersister.readModels(M
odelMemberFilePersister.java:274)
... 7 more
Caused by: org.netbeans.lib.jmi.util.DebugException: XMI version 
attribute is missing.
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.startElement(XmiSAXRe
ader.java:232)
at 
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.s
tartElement(AbstractSAXParser.java:504)
at 
com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.st
artElement(XMLDTDValidator.java:767)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl.scanStartElement(XMLDocumentFragmentScannerI
mpl.java:1370)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl$ContentDriver.scanRootElementHook(XMLDocumentScannerI
mpl.java:1316)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl$FragmentContentDriver.next(XMLDocumentFragme
ntScannerImpl.java:3115)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl$PrologDriver.next(XMLDocumentScannerImpl.java:921)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerI
mpl.next(XMLDocumentScannerImpl.java:647)
at 
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragment
ScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.
java:513)
at 
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.
parse(XML11Configuration.java:815)
at 
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.
parse(XML11Configuration.java:744)
at 
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XM
LParser.java:128)
at 
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.p
arse(AbstractSAXParser.java:1208)
at 
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSA
XParser.parse(SAXParserImpl.java:543)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.read(XmiSAXReader.jav
a:136)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.read(XmiSAXReader.jav
a:98)
at org.netbeans.lib.jmi.xmi.SAXReader.read(SAXReader.java:56)
at 
org.argouml.model.mdr.XmiReaderImpl.parse(XmiReaderImpl.ja
va:267)
... 8 more
Caused by: org.netbeans.lib.jmi.util.DebugException: XMI version 
attribute is missing.
at 
org.netbeans.lib.jmi.xmi.XmiContext.setVersion(XmiContext.java
:210)
at org.netbeans.lib.jmi.xmi.XmiElement$Document. 
(XmiElement.java:94)
at 
org.netbeans.lib.jmi.xmi.XmiSAXReader.startElement(XmiSAXRe
ader.java:169)
... 26 more

------------------------------------------------------------------------


-- 
Edit this bug report at https://pear.php.net/bugs/bug.php?id=20288&edit=1