From:  jgorland@gmail.com
Date:  05 Feb 2015 16:19:08 Hong Kong Time
Newsgroup:  news.php.net/php.pear.bugs
Subject:  

[PEAR-BUG] Bug #20499 [Fbk]: PHP Error Log file

NNTP-Posting-Host:  null

Edit report at https://pear.php.net/bugs/bug.php?id=20499&edit=1

 ID:               20499
 Updated by:       jgorland@gmail.com
 Reported By:      jgorland at gmail dot com
 Summary:          PHP Error Log file
 Status:           Feedback
 Type:             Bug
 Package:          PHP_CodeSniffer
 Operating System: Mac OSX Yosemite
 Package Version:  2.2.0
 PHP Version:      5.6.2
 Assigned To:      squiz
 Roadmap Versions: 
 New Comment:

the thing is this: I use CodeSniffer on Sublime Text 2 with the PSR-2
standard running.  But even if I 
close SublimeText 2 and stop Apache running from MAMP, these errors
still pop up so I'm not sure on 
which file this error is being triggered


Previous Comments:
------------------------------------------------------------------------

[2015-02-04 22:44:52] squiz

-Status:      Open
+Status:      Feedback
-Assigned To:
+Assigned To: squiz
The only way for me to diagnose the issue is for you to provide some
sample code that causes the 
problem, or point me at a project that I can run PHPCS over to find the
problem. Is there any chance 
you can do that?

I'd also need to know what standard you are running.

------------------------------------------------------------------------

[2015-02-04 22:32:31] hex4

Description:
------------
My php_error.log file is getting filled up with hundreds of the
following 
warnings per second (in few minutes the file is up to 1GB)

[04-Feb-2015 22:04:30 Europe/Berlin] PHP Notice:  Undefined index:  in 
/Applications/MAMP/bin/php/php5.6.2/lib/php/PHP/CodeSniffer/File.php on

line 3413
[04-Feb-2015 22:04:30 Europe/Berlin] PHP Notice:  Undefined index:  in 
/Applications/MAMP/bin/php/php5.6.2/lib/php/PHP/CodeSniffer/File.php on

line 3425

------------------------------------------------------------------------


-- 
Edit this bug report at https://pear.php.net/bugs/bug.php?id=20499&edit=1