From:  gsherwood@squiz.net
Date:  10 Dec 2014 06:42:25 Hong Kong Time
Newsgroup:  news.php.net/php.pear.bugs
Subject:  

[PEAR-BUG] Bug #20460 [Opn->Csd]: The new version of Codesniffer breaks my custom Sniffer

NNTP-Posting-Host:  null

Edit report at https://pear.php.net/bugs/bug.php?id=20460&edit=1

 ID:               20460
 Updated by:       gsherwood@squiz.net
 Reported By:      shahmirj at gmail dot com
 Summary:          The new version of Codesniffer breaks my custom
                    Sniffer
-Status:           Open
+Status:           Closed
 Type:             Bug
 Package:          PHP_CodeSniffer
 Operating System: Centos
 Package Version:  2.0.0
 PHP Version:      Irrelevant
-Assigned To:      
+Assigned To:      squiz
 Roadmap Versions: 
 New Comment:

-Status:      Open
+Status:      Closed
-Assigned To:
+Assigned To: squiz
The comment parser has been completely removed from version 2.0, so
you'll need to 
rewrite any custom sniffs that previously used it. More info is here: 
https://www.squizlabs.com/php-codesniffer/2.0.0a1-released

Look for the section "Removal of the Comment Parser".

If you are having problems converting your sniff, email me directly and
I'll help when I 
can: gsherwood at squiz dot net


Previous Comments:
------------------------------------------------------------------------

[2014-12-09 22:22:35] shahmirj

Description:
------------
When I run a `phpcs -p -n --standard=Custom --report-width=120 
./application` using a custom coding standard I get a backtrace. 

It seems that autoloading is not working

Note I am running 5.3.3 but version 1.5.6 works as expected. I 
have roll backed and tested

Test script:
---------------
A top level snippet of my code sniffer
https://gist.github.com/shahmirj/0159880803f6f08907dd

Expected result:
----------------
It to work, and use my custom sniffer

Actual result:
--------------
https://gist.github.com/shahmirj/6cabf77bdb6e7ad01cd8

------------------------------------------------------------------------


-- 
Edit this bug report at https://pear.php.net/bugs/bug.php?id=20460&edit=1