From:  phpdev@ehrhardt.nl (Jan Ehrhardt)
Date:  12 Dec 2012 13:01:47 Hong Kong Time
Newsgroup:  news.php.net/php.internals.win
Subject:  

Re: PHP OpenSSL v0.9.8 compatibility issue with OpenSSL v1.0

NNTP-Posting-Host:  null

Richard Genthner in php.internals.win (Mon, 10 Dec 2012 13:53:16 -0500):
>We have noticed a issue with compatibility with the openssl extension
>distributed with Windows PHP, when connecting to a server with OpenSSL
>v1.0. 
>
>WARNING: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages:
>error:14077458:SSL routines:SSL23_GET_SERVER_HELLO:reason(1112)

Take a look at
http://sourceforge.net/tracker/?func=detail&aid=3395520&group_id=976&atid=100976

This descibes your problem. As far as I know this occurs with every
0.9.8 version above 0.9.8g while connecting to a server with OpenSSL
1.0.x.

>Can we get a php_openssl.dll built with openssl 1.0 for php 5.3.19 ?

Try one of these:
http://dl.dropbox.com/u/8954372/openssl.zip

8 versions (x86/x64, zts/nts, 5.3.19/5.4.9) all with
OpenSSL 1.0.1c 10 May 2012.

Jan