From:  rgenthner@symplicity.com (Richard Genthner)
Date:  12 Dec 2012 00:05:22 Hong Kong Time
Newsgroup:  news.php.net/php.internals.win
Subject:  

Re: [INTERNALS-WIN] PHP OpenSSL v0.9.8 compatibility issue with OpenSSL v1.0

NNTP-Posting-Host:  null

Pierre,
	I installed the latest openssl for windows, but the php_openssl.dll is still 0.9.8, I can't get it build for me on windows 2008 r2 x64 (latest service packs). If you can just build me that extension, I'd be more then willing to test and let you know if it fixes the issue.
-- 
Thanks,

Richard Genthner
System Administrator
Symplicity
tel 703.351.0200 x 8051
web www.symplicity.com

On Dec 11, 2012, at 10:53 AM, Pierre Joye  wrote:

> hi,
> 
> On Tue, Dec 11, 2012 at 4:17 PM, Richard Genthner
>  wrote:
>> Pierre,
>>        It appears openssl sends down a "warning" about a new feature called SNI most clients, browsers,etc ignore the warning or treat it as non-fatal but it appears that curl treats it as a fatal. So what I'm thinking if we can get php 5.3.19 built with the latest openssl 1.0.1c and latest curl it might fix the fsockopen issue.
> 
> We can't and won't move to 1.x for 5.3/4 serie. 5.5 may get it tho'.
> 
> Did you try with latest openssl?
> 
> Cheers,
> --
> Pierre
> 
> @pierrejoye | http://blog.thepimp.net | http://www.libgd.org
>