From:  Paul Osman <paul@mozillafoundation.org>
Date:  06 Feb 2011 14:28:21 Hong Kong Time
Newsgroup:  news.mozilla.org/mozilla.drumbeat.website
Subject:  

Re: minimum python version

NNTP-Posting-Host:  63.245.208.166

On 11-02-05 11:35 PM, Bill Lovett wrote:
> I'm going through the install process and getting stuck at the syncdb step.
>
> I'm installing on Debian stable (lenny), which provides python 2.5.2.
> But apps/l10n/locales.py imports namedtuple from collections, and that
> requires 2.6. Is this a bug? I wasn't sure what the policy was
> regarding Python version compatibility.

Hi Bill,

Yes, Batucada uses namedtuple and uses decorators pretty extensively, 
which iirc are also >= 2.6.

We should make this more explicit. I'll make a note to add it to the 
README.

Cheers,
Paul