Yes, it will be the same as block/depend in term of notification.
Le 12/03/2019 à 19:12, David Major a écrit :
> Will setting the "regressed by" field send mail to the subscribers of
> the earlier bug? This was a useful aspect of the blocks/depends field.
> On Tue, Mar 12, 2019 at 1:59 PM Sylvestre Ledru wrote:
>> Le 12/03/2019 à 17:48, Andrew McCreight a écrit :
>>> On Tue, Mar 12, 2019 at 3:55 AM Sylvestre Ledru
>>>> With this change, we are going to extend Bugzilla to add a new field with
>>>> three new values:
>>>> Defect - an issue in one of our products
>>>> Enhancement - a new feature or an improvement
>>>> Task - a developer task. For example: refactor code foo.
>>> Could please you explain more what these three values are supposed to
>>> represent, possibly with some examples? It feels like there's a lot of
>>> overlap between them. For instance, isn't any task I work on as a developer
>>> a developer task? Isn't refactoring both a task and an improvement (and
>>> thus also an enhancement)?
>> * Defects are trivial. Examples:
>> Crashes, intermittent, glitches, features not working as expecting, features worked
>> but no longer works, etc.
>> This is mostly for users of our products (including ourself). Triaged by eng triage owners.
>> We decided NOT to call that bug as this word is super-overloaded at Mozilla.
>> * Enhancement is a development of a new feature. Examples:
>> add bar property in css 42, etc
>> This is mostly coming from users and us. Should be triagged by product and triage owners.
>> * Task is mostly development work. Examples:
>> Refactor function foo, remove function bar, improve function plop, etc.
>> Almost of them should be coming from engineering.
>> Now, we will have cases for which a ticket will be both a task and an enhancement.
>> Example: https://bugzilla.mozilla.org/show_bug.cgi?id=1528330
>> "Deliver acceptable GeckoView performance for Firefox Reality in H1"
>> But I am sure you will agree that this new state will still be an improvement over the current state.
>> Now, a more concrete example, I have want to implement a new feature in Firefox.
>> I will create (or reuse) a bug with the "enhancement" value (probably as a meta bug).
>> Then, to develop the feature, I will create various "tasks" which will be marking as
>> blocking the meta bug.
>> Because I am a bad developer, I will make mistakes and user will fill bugs which
>> will have the "defect" value (and I will use the regressed_by field).
>>> Secondly, to bikeshed a little, could there be some name besides "task" for
>>> that third category? Like I said above, everything we work as developers is
>>> a developer task. "Refactor" seems like a clearer name, though maybe it is
>>> a little limiting. "Side grade"? :)
>> This is more than just refactoring. It is more "as an engineer, here is what I have to do".
>> About bikeshed, you can have a look here https://bugzilla.mozilla.org/show_bug.cgi?id=1522342
>> Where we did that.
>>> Thirdly, what category should "organizational" bugs like meta bugs be
>>> assigned to? I guess if you have a meta bug for a bunch of enhancements, it
>>> would be an enhancement?
>> Yeah, "it depends" ;) Probably...
>>> 3) Adding a new field called “Regressed by”
>>> This is great! The weird encoding of "regressed by" in the "depends on"
>>> field is one of the more confusing aspects of Bugzilla, given how important
>>> it is. I spend a ton of time setting regressions for bugs, and even still I
>>> have to stop occasionally to make sure I'm doing it the right way.
>> Same here ;)
>> dev-platform mailing list